Xposed Framework ya es compatible con algunos Samsung Galaxy actualizados a Lollipop

Escrito por Víctor Rodríguez
Android

Xposed Framework, la popular herramienta que da más sentido si cabe a la Scene Android poco a poco se establece entre los dispositivos con Android 5.0 Lollipop. Sin embargo, en el caso de los equipos Samsung Galaxy la situación se complica en cierto grado puesto que el fabricante modifica la ejecución de la máquina virtual ART. Sin embargo, un desarrollador independiente ha logrado el modo de que sea posible instalar módulos mediante el framework de la app en los Samsung Galaxy con Android Lollipop, aunque con ciertas restricciones. Te detallamos todo a continuación.

Todo aquel que esté familiarizado con Xposed Framework sabrá que la noticia es un importante avance en el desarrollo de la Scene Android. Y es que esta potente herramienta es la pasarela a infinidad de modificaciones y personalizaciones en dispositivos Android. A través de los denominados módulos es posible optimizar el funcionamiento del equipo, mejorar su rendimiento o añadir infinidad de utilidades adicionales que de otro modo serían ciertamente complicadas de conseguir. Además, una vez instalado, Xposed facilita hasta el extremo el acceso a modificaciones que antes solo eran posibles mediante la instalación de archivos zip mediante recovery, entre otras cosas.Samsung Galaxy con Xposed Framework

De Dalvik a ART, uno de los inconvenientes

Con Android 4.4 KitKat no hubo problema. Xposed Framework es compatible, pero tras el desembarco de Android 5.0 Lollipop las cosas cambiaron puesto que la máquina virtual Dalvik daba paso a ART como tiempo de ejecución. Sus particularidades técnicas obligaban a los desarrolladores a recompilar la app, de modo que volviera a ser compatible. Sin embargo, en el caso de los Samsung Galaxy con Lollipop el tema varía respecto a las ROM AOSP dado que el propio fabricante retoca el tiempo de ejecución respecto a sus aplicaciones integradas en TouchWiz. De un modo u otro el problema para los propietarios de dispositivos Samsung Galaxy con Android 5.0 Lollipop seguía ahí, a pesar de que Xposed ya funciona en otros equipos con Lollipop.

Xposed para Samsung Galaxy

Por suerte, en los foros de XDA, la cuna de la scene Android, han encontrado el modo, por ahora extraoficial, de conseguir ejecutar los módulos de Xposed en ciertos modelos Samsung Galaxy con Android 5.0 Lollipop como versión de sistema. El único inconveniente, que el proceso de instalación es relativamente complicado, no apto para cualquiera. Todo aquel que quiera sumergirse en el proceso tiene todos los detalles con las explicaciones ofrecidas por el desarrollador en cuestión, que entre otras cosas, explica que es necesario deodexar la ROM antes de ejecutar Xposed. No dejes de visitar tampoco las FAQ de la herramienta.

También te puede interesar…

Fuente > AndroidBeat