[FALLO] Samsung Galaxy A5 2016 | Porcentaje Batería

alebote

Usuari@ MovilZona
Mensajes
6
#1
Buenas tardes compis, os voy a comentar el problema que tengo con el teléfono.

Siempre ha funcionado correctamente (excepto hace un año o dos que tuve que enviarlo al SAT por batería inflada); pero obviando eso, el teléfono funciona genial.

El problema: El teléfono desde hace 4 meses se apagaba al 15-20% completamente y no volvía a encender (se quedaba completamente seco de batería) y había que volver a cargarlo. He cambiado la batería y hace lo mismo solo que más acentuado (al 30%) y otro batería más (diferente) me hace lo mismo.

He formateado el teléfono, cambiado de ROM, etc, y Nada de Nada...

Mi teoría: El teléfono detecta que está cargado al 100% y en verdad esta al 80%, o sea, no lee bien el voltaje de batería. No se donde se encuentra el controlador de carga en este teléfono.
Leí hace tiempo que hay un archivo que controla esto, en el directorio / del teléfono, pero he supuesto que al cambiar la ROM esto se ha reseteado, por lo que no creo que este sea el problema.

Lo dicho compis, a ver si alguno podeis echarme un cable.
Un abrazo y gracias!!
 

RESIDENT

Moderador
Miembro del equipo
Mensajes
2,781
#2
  1. Buenas tardes compis, os voy a comentar el problema que tengo con el teléfono.
Siempre ha funcionado correctamente (excepto hace un año o dos que tuve que enviarlo al SAT por batería inflada); pero obviando eso, el teléfono funciona genial.

El problema: El teléfono desde hace 4 meses se apagaba al 15-20% completamente y no volvía a encender (se quedaba completamente seco de batería) y había que volver a cargarlo. He cambiado la batería y hace lo mismo solo que más acentuado (al 30%) y otro batería más (diferente) me hace lo mismo.

He formateado el teléfono, cambiado de ROM, etc, y Nada de Nada...

Mi teoría: El teléfono detecta que está cargado al 100% y en verdad esta al 80%, o sea, no lee bien el voltaje de batería. No se donde se encuentra el controlador de carga en este teléfono.
Leí hace tiempo que hay un archivo que controla esto, en el directorio / del teléfono, pero he supuesto que al cambiar la ROM esto se ha reseteado, por lo que no creo que este sea el problema.

Lo dicho compis, a ver si alguno podeis echarme un cable.
Un abrazo y gracias!!
Vamos por partes un buen cuidado de la batería implica:
  1. Cargar la batería cuando llegue al 20 % .
  2. No cargarla a tope si puedes dejarla al 80% mejor. Si algún día por alguna circunstancia especial tienes que llegar al 100 % porque no vas a tener acceso a un enchufe, lo haces, pero si puedes evitarlo mejor.
  3. Cuando termines inmediatamente quitarla del cargador.
Si no lo haces así se deterioran más rápido pero a veces no puedes cumplir todas las cosas.

Lo que puedes probar es un calibrado de batería consiste en:
  1. Carga el móvil hasta el 100%. Para acelerar el proceso, mejor apaga el teléfono mientras carga.
  2. Una vez esté la batería cargada al cien por cien desconecta el móvil del cargador y utiliza el teléfono hasta que la batería se descargue por completo (es decir, hasta que se apague el terminal).
  3. Deja que pasen algunas horas con el móvil apagado y, sin encenderlo de nuevo,
  4. Conecta el móvil a la corriente para cargar la batería hasta el 100%.
  5. Una vez se haya cargado por completo, desconectar de la corriente y la batería ya estará calibrada.
Podría funcionar suponiendo que la batería no esté mal.
 

alebote

Usuari@ MovilZona
Mensajes
6
#3
Vamos por partes un buen cuidado de la batería implica:
  1. Cargar la batería cuando llegue al 20 % .
  2. No cargarla a tope si puedes dejarla al 80% mejor. Si algún día por alguna circunstancia especial tienes que llegar al 100 % porque no vas a tener acceso a un enchufe, lo haces, pero si puedes evitarlo mejor.
  3. Cuando termines inmediatamente quitarla del cargador.
Si no lo haces así se deterioran más rápido pero a veces no puedes cumplir todas las cosas.

Lo que puedes probar es un calibrado de batería consiste en:
  1. Carga el móvil hasta el 100%. Para acelerar el proceso, mejor apaga el teléfono mientras carga.
  2. Una vez esté la batería cargada al cien por cien desconecta el móvil del cargador y utiliza el teléfono hasta que la batería se descargue por completo (es decir, hasta que se apague el terminal).
  3. Deja que pasen algunas horas con el móvil apagado y, sin encenderlo de nuevo,
  4. Conecta el móvil a la corriente para cargar la batería hasta el 100%.
  5. Una vez se haya cargado por completo, desconectar de la corriente y la batería ya estará calibrada.
Podría funcionar suponiendo que la batería no esté mal.

Buenas noches, ya he realizado varias calibraciones con diferentes baterías, por lo que dudo que sea esta el problema. Me huele a que es el controlador de carga, podría ser?

Muchas gracias por la ayuda!
Un saludo
 

RESIDENT

Moderador
Miembro del equipo
Mensajes
2,781
#4
Buenas noches, ya he realizado varias calibraciones con diferentes baterías, por lo que dudo que sea esta el problema. Me huele a que es el controlador de carga, podría ser?

Muchas gracias por la ayuda!
Un saludo
Unas dudas:

1) ¿Cuanto tiempo llevas con esa batería?
2) ¿La has cuidado como puse arriba? (Por lo menos no dejarla bajar del 20 % habitualmente)
3) ¿Eres de los que tiene ROM personalizada, recovery TWRP etc?
 

alebote

Usuari@ MovilZona
Mensajes
6
#5
Unas dudas:

1) ¿Cuanto tiempo llevas con esa batería?
2) ¿La has cuidado como puse arriba? (Por lo menos no dejarla bajar del 20 % habitualmente)
3) ¿Eres de los que tiene ROM personalizada, recovery TWRP etc?
Buenos dias!
1. Llevaré unos 2 meses, pero he probado varias y tengo el mismo problema
2. Sí, está perfectamente cuidada. No suelo dejarla tampoco pasar del 85/90%
3. He probado tanto completamente de fábrica, como con TWRP y otra ROM, con exáctamente el mismo resultado

Muchas gracias por el interés compi, espero poder solucionarlo!
 

RESIDENT

Moderador
Miembro del equipo
Mensajes
2,781
#6
Buenos dias!
1. Llevaré unos 2 meses, pero he probado varias y tengo el mismo problema
2. Sí, está perfectamente cuidada. No suelo dejarla tampoco pasar del 85/90%
3. He probado tanto completamente de fábrica, como con TWRP y otra ROM, con exáctamente el mismo resultado

Muchas gracias por el interés compi, espero poder solucionarlo!
¿Has probado ROM Stock + calibrado de batería? Si no quieres quitar TWRP supongo que también valdría una ROM stock personalizada.
 

alebote

Usuari@ MovilZona
Mensajes
6
#7
¿Has probado ROM Stock + calibrado de batería? Si no quieres quitar TWRP supongo que también valdría una ROM stock personalizada.
Buenas, he ahora mismo tengo cargada la Stock con el mismo problema y calibré la batería ayer por última vez-
He probado tanto con como sin TWRP
 

RESIDENT

Moderador
Miembro del equipo
Mensajes
2,781
#8
Buenas, he ahora mismo tengo cargada la Stock con el mismo problema y calibré la batería ayer por última vez-
He probado tanto con como sin TWRP
Es batería que tienes por lo que comentas es nueva, dices que tiene dos meses.

1) ¿Es una batería original?
2) ¿Tiene garantía?
3) ¿Al menos te dura la batería como la anterior? (Aproximadamente).
 

alebote

Usuari@ MovilZona
Mensajes
6
#9
Es batería que tienes por lo que comentas es nueva, dices que tiene dos meses.

1) ¿Es una batería original?
2) ¿Tiene garantía?
3) ¿Al menos te dura la batería como la anterior? (Aproximadamente).
1. Mismo problema tanto con original como con no original
2. No, no tiene garantía
3. Sí, igual que la anterior

Gracias por la ayuda!
 

alebote

Usuari@ MovilZona
Mensajes
6
#11
¿Antes de instalar haces los 3 Wipes desde el TWRP? (data, dalvik y cache). @tzadkiel2 ¿Se te ocurre algo más?
Buenas, si, he probado a hacer completamente todo.
No se que más hacer.

Hoy tras todo el dia, he descubierto una cosa. Se apaga al 50%+-8 porque el teléfono al llegar al 50%+- deja de cargar. Es decir, corta la entrada de corriente y el porcentaje sube pero la betería NO está cargando, por eso se apaga antes de tiempo. Según apps, el voltaje llega hasta los 4.7V, cosa que me parece excesiva, pero no creo que sea verdad, ya que el teléfono no llega a calentarse cargando.
Lo dicho, yo diría que es el Controlador de carga, que en este teléfono no es caro, pero no dispongo de pistola de calor para poder cambiarlo; así que creo que hasta aquí ha llegado este gran soldado, jeje.
He probado incluso a modificar el archivo que se encuentra en /efs/FactoryApp/batt_discharge_level y no ha habido suerte.


Si se os ocurre algo os escucho. Muchísimas gracias sobre todo a Resident por la ayuda!
Un saludo!
 

tzadkiel2

Usuari@ MovilZona
Mensajes
6,557
#12
@RESIDENT Yo le cambiaría el puerto de carga, pero si dice que no tiene con qué abrir el teléfono ....
@alebote Yo no modificaría esos archivos y menos aún para bajar el nivel. Algo similar con el S9+ me tocó sustituirle el puerto de carga por problemas similares, cargaba cuando le daba la gana .....
 
Arriba